Connecting an Emulator to Internet on Vista Business

A couple of weeks ago I got a new laptop from office. It is a Dell Latitude D630 running Vista Business. I didn’t get much time to setup the machine, just did the bare essentials to do my day to day work. And during the last long weekend, since I had sometime in my hands, I started setting up my development environments on it.

I started off with Visual Studio 2003 as the main solution that I need to support on my new job is a ASP.NET 1.1 application. Through officially VS2003 is not supported on Vista, I managed to install and run it on my machine. I still havent done any debugging or anything yet, but hope I wont face much issues. In case I do, i do have another laptop running Windows XP, on which I have installed VS2003.

Then came my favourite IDE, VS2005. Installed the Professional Edition and WM5 SDK’s and tried to do some changes to moBlog. Managed to do the changes, but was not able to test it as I could not get the emulator to connect to the Internet. Also, since I have switched my mobile also to a Blackberry I did not have a device to test it on either.

Ended up installing an untold number of software on my laptop including Virtual PC, patches, WM6 SDK’s, you name it. But still I cannot get my emulator to connect to the Internet. The Windows Mobile Device Center (WMDC) only started to recognize the cradling of the emulator after I installed MS Virtual PC. Now, when I cradle the emulator, WMDC recognizes and initiated a connection. But still I cannot browse the Internet from the emulator.

When I try to browse a web site from it, I get a message saying that “Page cannot be found. Check the name and try again”. From moBlog, I get a exception saying that the remote host name cannot be resolved. I know the issue is with the connectivity between the emulator and machine. But right now I have run out of ideas. And I could not find much information on the Internet regarding connecting emulators to Internet using WMDC. All the articles refer to ActiveSync. But the information is straight forward enough to apply to WMDC, unless there are any specific things that you need to do with WMDC.

Any ideas or suggestions are welcome!

UPDATE: I allowed WMDHost (C:\Windows\WindowsMobile\WmdHost.exe) through the firewall and it happened to solve the problem.  Voila! Now my .NETCF programs can connect to the Internet through the Emulator!


  1. I had an issues of not being able to connect the Mobile device to Vista, add the following exception to the firewall and also installed Device Emulator 3 rather that version 1.

    Jamie

  2. Daniel

    Thanks a bunch for this post, saved me lots of time!!




Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s



%d bloggers like this: