moBlog on msmobiles.com

msmobiles.com has just published a news item about the release of moBlog. You can find it here.


  1. liam

    I am hosting my wordpress on my site and I seem to not be able to retrieve settings. it gives me this error
    “an error message cannot be displayed because an optional resource assembly containing it cannot be found.”

    I have ce .net framework on my htc tytn running WM6.

    Thank you

  2. liam

    Edit I installed the error reporting debug package for .net 2.0 and the real error message is “the remote name could not be resolved.” I guess your blog software doesnt support having wordpress running on your own site. So I would like to put a request for this. Thank you.

  3. hi Liam,

    Since you are running your own WordPress intallation, instead of the blog url, give it the url of the admin module. I think in the wordpress installation the XML RPC endpoint is located within the admin module.

    So if your blog is: http:www/liamsblog.com and if your login pag eis located at http://liamsblog.com/wp-admin/ give http://liamsblog/wp-admin/ as your blog url. This would then be able to connect to your blog.

    Please let me know if this works for you.

    Cheers,
    Sampath.

  4. tc

    looking forward to trying this when im back from christmas, thanks for making it!
    If it doesnt already have it, could you please let us upload picture attachments with our posts? it would be cool to see something, snap a picture, then post this to my blog.

  5. liam

    Okay actually the problem was on my end, but thank you for your reply.
    One problem I found is when trying to open a saved blog.
    I get this error
    “An unexpected error has occured in moBlog.exe.
    Select Quit and then restart this program, or select Details for form information.”
    “Specified argument was out of the range of valid values.”
    If I push details I get

    moBlog.exe
    ArgumentOutOfRangeException
    Specified argument was out of the range of valid values.

    at System.Collections.ArrayList.get_Item()
    at ListViewItemCollection.get_Item()
    at moBlog.frmPost.frmPost_Load()
    at System.Windows.Forms.Form.OnLoad()
    at System.Windows.Forms.Form._SetVisibleNotify()
    at System.Windows.Forms.Control.set_Visible()
    at moBlog.frmSavedPosts.mnuOpen_Click()
    at System.Windows.Forms.MenuItem.OnClick()
    at System.Windows.Forms.Menu.ProcessMnuProc()
    at System.Windows.Forms.Form.WnProc()
    at System.Windows.Forms.Control._InternalWnProc()
    at Microsoft.AGL.Forms.EVL.EnterMainLoop()
    at System.Windows.Forms.Application.Run()
    at moBlog.Program.Main()

    But if I publish one directly without saving it, it does publish the blog, but I get an error. “Response from server does not contain valid XML.”

    One more thing. on my Today screen moBlog has the default program icon. Is it supposed to have its own icon?

    Again, Thanks for your time.

  6. Hi,

    Liam – Found the issue with opening a saved entry. Will post a fix soon. But could not simulate the second issue. Can you give me a bit more details, such as were any categories selected for the blog post? What was in the post body? in title?

    Currently moBlog does not have its own icon. The reason being I suck when it comes to graphics. So if there is anyone who is willing to design an icon, I will be glad to use it and give credits as well.

    TC, the feature you requested is not there currently. But I sure will add it to planned features. Give it a spin and let me know what you think.

    Cheers,
    Sampath.

  7. Liam

    Actually I found my problem (again my fault)
    I use a plugin for wordpress that looks at what the browser sends as the version the person is using. If its mobile (or PPC) It makes it so it looks okay on a PPC.
    What does your application send to the site as an identifier?

    Thank you, for the fix on the other problem. I also am not an artsy person so no help from me on the icon.
    But I might know someone who can. Any sort of animal or anything you like? Maybe I can get my friend to make something.

  8. hi Liam,

    I use Metaweblog API to communicate with WordPress. So what is sent is the Post structure that is defined there.

    As for the icon, I guess I”d like something with a PDA / Smartphone maybe. I guess an arty person will come up with something way better than what I can imagine!

    Cheers,
    Sampath.




Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s



%d bloggers like this: